Как исправить сообщения «Эта версия Safari больше не поддерживается»

Более старые версии OS X не получают новейших исправлений от Apple. Так работает программное обеспечение. Если старая версия OS X, которую вы используете, больше не получает важных обновлений для Safari, вам сначала придется выполнить обновление до более новой версии OS X. Как долго вы решите обновить свой Mac, полностью зависит от вас. Но определенно пора навести порядок, потому что есть веские причины, по которым вы получаете сообщение «Эта версия Safari больше не поддерживается», и они обычно связаны с безопасностью или возможностями, которых вам не хватает.

У меня MacBook Pro 2009 года выпуска. Он работает нормально, но я продолжаю получать сообщения «Эта версия Safari больше не поддерживается. Пожалуйста, обновите браузер до поддерживаемого». Я также не могу скачать определенные программы или открыть некоторые видео с YouTube. Следует ли мне обновить свой браузер, и если да, то следует ли использовать Yosemite? Кроме того, если я перейду на другой браузер, то внешний вид моего экрана существенно изменится. (Я один из тех, кто не любит никаких изменений.) Спасибо за любую помощь, которую вы можете предложить. — KC

Я довольно часто сталкиваюсь с этой проблемой в магазине, в котором работаю. Клиент придет с Mac, который отлично работает, за исключением того, что он больше не может многое делать в Интернете, потому что продолжает получать это сообщение об ошибке.

Это сообщение об ошибке является законным: некоторые веб-сайты будут блокировать вам доступ к своему содержимому, если они сочтут вас угрозой безопасности или если браузер, с которым вы работаете, слишком старый для поддержки технологии, от которой они зависят. К сожалению, в этих условиях вы ничего не можете сделать, кроме как заставить ваш Mac работать с более современным программным обеспечением.

Некоторые люди, читающие это, могут быть удивлены, узнав, что вы еще не используете OS X Yosemite, в конце концов, она должна нормально работать на Mac эпохи 2009 года. Но факт в том, что многие из нас, как и вы, используют наши Mac с программным обеспечением, с которым они пришли, потому что это то, к чему мы привыкли и что нам нравится использовать. И как гласит старая пословица, если он не сломан, не чините его.

Вы не сказали мне, как был настроен ваш MacBook Pro, но если это 13-дюймовая модель и если вы попадаете в лагерь «если он не сломался», я предполагаю, что пришел ваш MacBook Pro 2009 года с OS X 10.5 «Леопард», которая является устаревшая операционная система по стандартам Apple.

Плохая новость в том, что вы не можете произвольно прыгнуть в Йосемити. В конце концов, для этого вам понадобится Mac App Store, а вы этого не сделаете. имеют Mac App Store на вашем Mac, потому что он не был представлен до тех пор, пока Snow Leopard не вышел позже в том же году.

Хорошая новость заключается в том, что Apple по-прежнему предлагает Snow Leopard для продажи — вы можете купить его на DVD прямо у Apple за 19,99 доллара. Это также доступны у поставщиков на Amazon.com, хотя это будет стоить вам немного дороже.

Установка Snow Leopard на свой Mac с необходимыми обновлениями безопасности и приложений может привести вас к тому моменту, когда вы нет больше не видеть неподдерживаемые сообщения браузера; вы также можете скачать Fire Fox или же Гугл Хром в таком случае; оба этих веб-браузера также продолжают поддерживать Snow Leopard.

Хорошая новость заключается в том, что Snow Leopard достаточно похож по внешнему виду на Leopard, чтобы быть очень ненавязчивое обновление для вас. Вы должны уметь применять его без каких-либо серьезных осложнений, которые могут испортить то, к чему вы привыкли.

Обновление вашего Mac до Snow Leopard и применение любых обновлений программного обеспечения предоставит вам доступ к Mac App Store, и вы сможете дополнительно обновить свой Mac оттуда, если захотите.

Может ли ваш Mac запускать Yosemite? Да, может — хотя есть несколько предостережений. Прежде всего, вам понадобится как минимум 2 ГБ ОЗУ, и я бы действительно рекомендовал установить 4 ГБ или более. (Если вы не знаете, сколько оперативной памяти у вашего Mac, перейдите в меню  и нажмите «Об этом Mac», он должен сообщить вам об этом.) Во-вторых, Yosemite делает внести в операционную систему Mac множество визуальных изменений, которые могут вам не понравиться. Так что Snow Leopard может быть вашим лучшим выбором.

Тем не менее, Snow Leopard — ваш первый остановитесь, прежде чем идти дальше, потому что Leopard определенно прошел на этом этапе своего расцвета.

Мы можем получать комиссию за покупки, используя наши ссылки. Узнать больше.

var fbAsyncInitOrg = window.fbAsyncInit; window.fbAsyncInit = function() { if(typeof(fbAsyncInitOrg)=='function') fbAsyncInitOrg(); FB.init({ appId: "291830964262722", xfbml: true, version : 'v2.7' });

FB.Event.subscribe('xfbml.ready', function(msg) { // Log all the ready events so we can deal with them later var events = fbroot.data('ready-events'); if( typeof(events) === 'undefined') events = []; events.push(msg); fbroot.data('ready-events',events); });

var fbroot = $('#fb-root').trigger('facebook:init'); };

Добавить комментарий

Ваш адрес email не будет опубликован.